How do you name the response event of a general button?

how do you name the response event of a general button?

<Button type="warning" @click="buy_btn_click(index)"></Button>

I like to use * _ btn_click , and I don"t know what name everyone uses to standardize it.

Feb.28,2021

is generally named according to the meaning of this button operation. For example, save: save, cancel: cancle.


I generally are:
onBuyBtnClick or handleBuy


generally: button event English + Btn


.
since you are binding a click event, why add click after it? isn't that troublesome?
and still use an underscore, so typing is even more troublesome.
as far as my personal habit is concerned,
response event naming adopts the hump form of verb + noun
such as
get + Order
get + UserName


Hump naming: getInstance
underscore Segmentation: get_username

Menu